Cisco VRRP Configuration: Can I use a /30 on VLAN Subinterface - cisco

I have been unable to find any documentation or examples where a /30 was used to configure a VRRP interface on a cisco router. Is this possible, if so does anybody have an example?
interface GigabitEthernet0/0.1507
description CUSTOMER WAN
encapsulation dot1Q 1507
ip address X.X.X.X 255.255.255.252 // I don't have an extra IP
vrrp 150 address 10.102.32.210
vrrp 150 description VLAN 1507
vrrp 150 priority 150
vrrp 150 timers advertise 110
vrrp 150 timers learn
vrrp 150 track 100 decrement 60
vrrp 150 authentication text mypass
no shut
I understand this is the correct syntax, but obviously, when I have to use a /30 WAN I don't have an extra IP for the standby router's interface.
interface GigabitEthernet0/1.77
description INTERNAL VLAN
encapsulation dot1Q 77 native
ip address 10.40.77.2 255.255.255.0 // 77.3 on Standby
vrrp 77 description VLAN 77
vrrp 77 ip 10.40.77.1
vrrp 77 priority 150
vrrp 77 timers advertise 110
vrrp 77 timers learn
vrrp 77 track 100 decrement 60
vrrp 77 authentication text mypass
no shut
Thank you in advance!
ADDING INTERFACE CONFIG
redundancy
!
track 100 interface GigabitEthernet0/1 ip routing
!
interface GigabitEthernet0/0
no ip address
no shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/0.75
encapsulation dot1Q 75
ip address 75.124.154.2 255.255.255.252
vrrp 75 description VLAN 75
vrrp 75 priority 150
vrrp 75 timers advertise 110
vrrp 75 timers learn
vrrp 75 track 100 decrement 60
vrrp 75 authentication text vrrp75!
no shut
!
interface GigabitEthernet0/0.76
encapsulation dot1Q 76
ip address 75.124.154.6 255.255.255.252
vrrp 76 description VLAN 76
vrrp 76 priority 150
vrrp 76 timers advertise 110
vrrp 76 timers learn
vrrp 76 track 100 decrement 60
vrrp 76 authentication text vrrp76!
no shut
!
interface GigabitEthernet0/0.104
encapsulation dot1Q 104
ip address 10.40.1.5 255.255.255.252
vrrp 104 description VLAN 104
vrrp 104 priority 150
vrrp 104 timers advertise 110
vrrp 104 timers learn
vrrp 104 track 100 decrement 60
vrrp 104 authentication text vrrp104!
no shut
!
interface GigabitEthernet0/0.105
descriptio
encapsulation dot1Q 105
ip address 10.40.1.9 255.255.255.252
vrrp 105 description VLAN 105
vrrp 105 priority 150
vrrp 105 timers advertise 110
vrrp 105 timers learn
vrrp 105 track 100 decrement 60
vrrp 105 authentication text vrrp105!
no shut
!
interface GigabitEthernet0/0.149
encapsulation dot1Q 149
ip address 149.6.154.70 255.255.255.240
vrrp 149 description VLAN 149
vrrp 149 priority 150
vrrp 149 timers advertise 110
vrrp 149 timers learn
vrrp 149 track 100 decrement 60
vrrp 149 authentication text vrrp149!
crypto map VPN_Tunnel
no shut
!
interface GigabitEthernet0/0.165
encapsulation dot1Q 165
ip address 165.42.149.206 255.255.255.252
vrrp 165 description VLAN 165
vrrp 165 priority 150
vrrp 165 timers advertise 110
vrrp 165 timers learn
vrrp 165 track 100 decrement 60
vrrp 165 authentication text vrrp165!
no shut
!
interface GigabitEthernet0/0.166
encapsulation dot1Q 166
ip address 165.43.149.86 255.255.255.252
vrrp 166 description VLAN 166
vrrp 166 priority 150
vrrp 166 timers advertise 110
vrrp 166 timers learn
vrrp 166 track 100 decrement 60
vrrp 166 authentication text vrrp166!
no shut
!
interface GigabitEthernet0/0.194
encapsulation dot1Q 194
ip address 209.198.218.1 255.255.255.128
ip nat outside
vrrp 194 description VLAN 194
vrrp 194 priority 150
vrrp 194 timers advertise 110
vrrp 194 timers learn
vrrp 194 track 100 decrement 60
vrrp 194 authentication text vrrp194!
no shut
!
interface GigabitEthernet0/0.1507
encapsulation dot1Q 1507
ip address 10.102.32.210 255.255.255.252
vrrp 150 description VLAN 1507
vrrp 150 priority 150
vrrp 150 timers advertise 110
vrrp 150 timers learn
vrrp 150 track 100 decrement 60
vrrp 150 authentication text vrrp150!
no shut
!
interface GigabitEthernet0/0.2149
encapsulation dot1Q 2149
ip address 149.84.6.129 255.255.255.128
vrrp 214 description VLAN 2149
vrrp 214 priority 150
vrrp 214 timers advertise 110
vrrp 214 timers learn
vrrp 214 track 100 decrement 60
vrrp 214 authentication text vr!
no shut
!
!
!
!
!
interface GigabitEthernet0/1
no ip address
no shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1.77
encapsulation dot1Q 77 native
ip address 10.40.77.2 255.255.255.0
ip nat inside
vrrp 77 description VLAN 77
vrrp 77 ip 10.40.77.1
vrrp 77 priority 150
vrrp 77 timers advertise 110
vrrp 77 timers learn
vrrp 77 track 100 decrement 60
vrrp 77 authentication text vrrp77!
no shut
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!

This configuration is not possible according to standards. You need to have a /29 subnet mask. Three IP addresses for two vrrp routers, and one for each client. It is answered in the following question.
https://networkengineering.stackexchange.com/questions/25171/vrrp-sharing-master-routers-ip
Now, some have tried a work around, by assigning secondary ip address for /30 subnet mask, but if you have the option to control remote side, then it defeats the purpose. You can just use a /29 mask instead. Here is a link for using secondary address.
https://lathiat.livejournal.com/36658.html
Router1:
interface FastEthernet1/0
ip address 192.168.1.1 255.255.255.0
vrrp 1 ip 192.168.1.10
vrrp 1 ip 192.168.100.1 secondary
!
ip route 192.168.100.0 255.255.255.252 FastEthernet1/0
Router2:
interface FastEthernet1/0
ip address 192.168.1.2 255.255.255.0
vrrp 1 ip 192.168.1.10
vrrp 1 ip 192.168.100.1 secondary
!
ip route 192.168.100.0 255.255.255.252 FastEthernet1/0

Related

DNS lookup failing over ethernet but not USB

I currently have two different 5g routers. My PC's wifi doesn't work, so I'm only able to connect either of them through wired connection. The old one that I want to get rid of uses a usb, and works. The new one uses ethernet, and fails with DNS lookup (ping www.google.com fails but ping 8.8.8.8 succeeds.)
resolve.conf looks like:
# Generated by NetworkManager
search lan
nameserver 192.168.1.1
nameserver fe80::d4bb:5cff:fe4e:6313
nameserver fe80::38:40ff:fe30:419e
# NOTE: the libc resolver may not support more than 3 nameservers.
# The nameservers listed below may not be recognized.
nameserver fe80::34e1:ffff:fe65:f72b
nameserver fe80::d43f:21ff:fe59:462a
nameserver 192.168.12.1
nameserver fe80::ca99:b2ff:fee7:71f5%enp5s0
nameserver fe80::d43f:21ff:fe59:462a%enp6s0f1u1
nmcli yields:
enp5s0: connected to Wired connection 1
"Intel I211"
ethernet (igb), 3C:7C:3F:1E:C6:01, hw, mtu 1500
ip4 default, ip6 default
inet4 192.168.12.232/24
route4 192.168.12.0/24 metric 100
route4 default via 192.168.12.1 metric 100
inet6 2607:fb90:3307:6e5d:91df:e64b:949:c78c/128
inet6 2607:fb90:3307:6e5d:bcb3:1b35:1589:bd17/64
inet6 fe80::48f9:3fb0:7e83:d1a7/64
route6 2607:fb90:3307:6e5d:91df:e64b:949:c78c/128 metric 100
route6 2607:fb90:3307:6e5d::/64 metric 100
route6 fe80::/64 metric 1024
route6 default via fe80::ca99:b2ff:fee7:71f5 metric 100
enp6s0f1u1: connected to Wired connection 2
"Novatel Wireless M2000"
ethernet (rndis_host), 00:15:FF:30:51:72, hw, mtu 1428
inet4 192.168.1.5/24
route4 192.168.1.0/24 metric 101
route4 default via 192.168.1.1 metric 101
inet6 2607:fb90:3395:673a:5552:7f52:abd9:488e/64
inet6 fe80::20b0:4b16:c9f:e9d0/64
route6 fe80::/64 metric 1024
route6 2607:fb90:3395:673a::/64 metric 101
route6 default via fe80::d43f:21ff:fe59:462a metric 101
"Wired connection 2" is the one that works (the USB one.)
So I'm pretty clear that my resolv.conf is specifically telling the usb interface to use one DNS server (fe80::d43f:21ff:fe59:462a) that works, and telling the ethernet interface to use another (fe80::ca99:b2ff:fee7:71f5) that fails. I just don't know why it's doing that, or how to make it stop (given that I think NetworkManager generates that file, and will presumably re-generate it if I just edit it myself.)
What happen? What do?

Port with VLAN not working on Cisco switch [closed]

Closed. This question does not meet Stack Overflow guidelines. It is not currently accepting answers.
This question does not appear to be about a specific programming problem, a software algorithm, or software tools primarily used by programmers. If you believe the question would be on-topic on another Stack Exchange site, you can leave a comment to explain where the question may be able to be answered.
Closed 1 year ago.
Improve this question
I'm having issues with a cisco SG550X-24 switch.
The switch is showing 100U as an administrative VLAN but not an operation VLAN. I'm unsure why this is, and plugging into this port doesn't work. The switch functions normally and other ports work fine.
Screenshot of config page attached:
cisco vlan config
1 and 19 are configured exactly and same, port 19 works fine with 100U but port 1 doesn't.
Any ideas? Is there a setting I'm missing that disables the port or VLAN?
Thanks
config-file-header
CB-BR-Radon233
v2.5.5.47 / RTESLA2.5.5_930_364_286
CLI v1.0
file SSD indicator encrypted
#
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
!
unit-type-control-start
unit-type unit 1 network gi uplink te
unit-type unit 2 network gi uplink te
unit-type unit 3 network gi uplink te
unit-type unit 4 network gi uplink te
unit-type unit 5 network gi uplink te
unit-type unit 6 network gi uplink te
unit-type unit 7 network gi uplink te
unit-type unit 8 network gi uplink te
unit-type-control-end
!
port jumbo-frame
vlan database
vlan 2,69,100,201
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
link-flap prevention disable
no boot host auto-config
no boot host auto-update
bonjour interface range vlan 1
hostname IMS-CB-BR-Radon233
no passwords complexity enable
username root password encrypted 777f99c04f34de13899c397960ac60d7548cfeb4 privilege 15
username cisco password encrypted ffd1c8e37222f7a9f61aec3e1179e951695fdeba privilege 15
ip ssh server
snmp-server location CB-BR-Radon233
snmp-server contact
clock timezone J 0 minutes 0
!
interface vlan 1
ip address 192.168.1.233 255.255.255.0
no ip address dhcp
!
interface vlan 2
name Phone
!
interface vlan 69
name Dirty
!
interface vlan 100
name Admin
ip address 192.168.100.233 255.255.255.0
!
interface vlan 201
name Mocap
!
interface GigabitEthernet1/0/1
no switchport
switchport access vlan 100
switchport trunk native vlan 100
!
interface GigabitEthernet1/0/3
storm-control broadcast level 10
storm-control multicast level 10
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
spanning-tree bpduguard enable
switchport mode trunk
switchport trunk allowed vlan 1
macro description ip_phone_desktop
!next command is internal.
macro auto smartport dynamic_type ip_phone_desktop
!
interface GigabitEthernet1/0/4
storm-control broadcast level 10
storm-control multicast level 10
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
spanning-tree bpduguard enable
switchport mode trunk
switchport access vlan 2
switchport trunk allowed vlan 1
macro description ip_phone_desktop
!next command is internal.
macro auto smartport dynamic_type ip_phone_desktop
!
interface GigabitEthernet1/0/7
storm-control broadcast level 10
storm-control multicast level 10
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
spanning-tree bpduguard enable
switchport mode trunk
switchport trunk allowed vlan 1
macro description ip_phone_desktop
!next command is internal.
macro auto smartport dynamic_type ip_phone_desktop
!
interface GigabitEthernet1/0/11
storm-control broadcast level 10
storm-control multicast level 10
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
spanning-tree bpduguard enable
switchport mode trunk
switchport access vlan 2
switchport trunk allowed vlan 1
macro description ip_phone_desktop
!next command is internal.
macro auto smartport dynamic_type ip_phone_desktop
!
interface GigabitEthernet1/0/12
channel-group 1 mode auto
!
interface GigabitEthernet1/0/13
switchport mode trunk
switchport access vlan 100
switchport trunk allowed vlan none
!
interface GigabitEthernet1/0/19
switchport access vlan 100
switchport trunk native vlan 100
!
interface GigabitEthernet1/0/24
channel-group 1 mode auto
!
interface TenGigabitEthernet1/0/1
channel-group 2 mode auto
!
interface TenGigabitEthernet1/0/2
channel-group 2 mode auto
!
interface TenGigabitEthernet1/0/3
spanning-tree link-type point-to-point
switchport mode trunk
switchport trunk allowed vlan 1-2,69,100,201
macro description switch
!next command is internal.
macro auto smartport dynamic_type switch
!
interface Port-Channel1
description EthTrunk
spanning-tree link-type point-to-point
switchport mode trunk
switchport general allowed vlan add 2,69,100,201 tagged
switchport general allowed vlan add 1 untagged
macro description switch
!next command is internal.
macro auto smartport dynamic_type switch
!
interface Port-Channel2
description X1Trunk
switchport mode trunk
!
exit
assuming you're using the same device and the same ethernet-cable when connecting to port 1 and port 19, correct?
would you mind to SSH into the switch and collect a "show run" for port 1 and 19?
...ok, with the config provided:
this is weird, port 1 is configured as routed port but the vlan-settings are still there.
my first try would be:
(in the ssh shell)
conf t
interface GigabitEthernet1/0/1
switchport
end
that should fix the vlan-membership.
a good practice for end-user-facing interfaces would be to add:
conf t
interface GigabitEthernet1/0/1
spanning-tree portfast
spanning-tree bpduguard enable
end

ASA 5505 mac address allocation issue

I have a ASA 5505 in transparent mode with a Security plus licence
Licensed features for this platform:
Maximum Physical Interfaces : 8 perpetual
VLANs : 20 DMZ Unrestricted
Dual ISPs : Enabled perpetual
VLAN Trunk Ports : 8 perpetual
Inside Hosts : Unlimited perpetual
Failover : Active/Standby perpetual
Encryption-DES : Enabled perpetual
Encryption-3DES-AES : Enabled perpetual
AnyConnect Premium Peers : 25 perpetual
AnyConnect Essentials : 25 perpetual
Other VPN Peers : 25 perpetual
Total VPN Peers : 25 perpetual
Shared License : Enabled perpetual
AnyConnect for Mobile : Enabled perpetual
AnyConnect for Cisco VPN Phone : Enabled perpetual
Advanced Endpoint Assessment : Enabled perpetual
UC Phone Proxy Sessions : 2 perpetual
Total UC Proxy Sessions : 2 perpetual
Botnet Traffic Filter : Enabled perpetual
Intercompany Media Engine : Disabled perpetual
Cluster : Disabled perpetual
Whilst attempting to edit a vlan with the command: int vlan 7
I receive back ERROR: % Cannot allocate MAC address to interface
Is this related to the error message in the ASDM when clicking add new interface i receive the error message "You cannot have more than 3 vlans in your system"? And if so why do i get this message?
ASA Version 9.1(6)8
!
firewall transparent
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
switchport access vlan 3
shutdown
!
interface Ethernet0/3
switchport access vlan 4
shutdown
!
interface Ethernet0/4
switchport access vlan 5
shutdown
!
interface Ethernet0/5
switchport access vlan 6
shutdown
!
interface Ethernet0/6
switchport access vlan 7
!
interface Ethernet0/7
switchport access vlan 8
!
interface Vlan1
description Management Pc Connection
nameif inside
bridge-group 1
security-level 100
!
interface Vlan2
description Dead End - No Connection
nameif outside
bridge-group 1
security-level 0
!
interface Vlan8
description Management Pc Connection
nameif ManPc-HpILO
bridge-group 4
security-level 100
!
interface BVI1
description ASA Management Bridge Group
ip address
!
interface BVI3
description Vmware Bridge Group
ip address
!
interface BVI4
description HP ILO 4 Bridge Group
ip address
!
ftp mode passive
pager lines 24
mtu outside 1500
mtu inside 1500
mtu ManPc-HpILO 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http inside
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
no ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:e02cea00fefdea428cbbd8994f237335
: end
I was not aware that transparent mode does not quite share the licence allowance.
According to Cisco,
Security Plus License + Transparent Mode
3 active VLANs
(2 active VLANs in 1 bridge group, plus 1 active VLAN for failover)

Linux port based routing

I have a requirement to host a java application on a server which can simulate multiple devices each one with separate IP address. The scalability requirements are so large that I cannot think of launching VMs or any containers.
The way I thought about supporting this is to have the application listen on a particular port on 127.0.0.1 , add a route to forward all the packets destined to say 192.168.0.1/24 (internal addresses where clients connected to my server will send packets) forward to 127.0.0.1:
Is this the best way of implementing or any other better options available.
You can create multiple loopback interface, in addition to 127.0.0.1, you can create a loopback interface on 127.0.0.2, 127.0.0.3, etc... Each one of them will be a loopback interface of its own.
ifconfig tells you:
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 0 (Local Loopback)
RX packets 353847 bytes 99880673 (95.2 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 353847 bytes 99880673 (95.2 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
Note that the netmask is 255.0.0.0

Redhat Enterprise Linux 6 Multicast Feed

I am writing an application which receives multicast data on a new Redhat Enterprise Linux 6 server. The support team gives me an application which is used for testing whether the server can get multicast data flow.
Once I start the test application, and also having tcpdump running,
I can see the multicast data coming in, e.g.,
12:58:21.645968 IP 10.26.12.22.50002 > 238.6.6.36.50002: UDP, length 729
12:58:21.648369 IP 10.26.12.22.50002 > 238.6.6.36.50002: UDP, length 969
12:58:21.649406 IP 10.26.12.22.50002 > 238.6.6.36.50002: UDP, length 893
12:58:21.651823 IP 10.26.12.22.50002 > 238.6.6.36.50002: UDP, length 604
12:58:21.654079 IP 10.26.12.22.50002 > 238.6.6.36.50002: UDP, length 913
12:58:21.656724 IP 10.26.12.22.50002 > 238.6.6.36.50002: UDP, length 1320
12:58:21.658194 IP 10.26.12.22.50002 > 238.6.6.36.50002: UDP, length 124
12:58:21.658226 IP 10.26.12.22.50002 > 238.6.6.36.50002: UDP, length 217
12:58:21.658348 IP 10.26.12.22.50002 > 238.6.6.36.50002: UDP, length 182
12:58:21.658625 IP 10.26.12.22.50002 > 238.6.6.36.50002: UDP, length 1014
12:58:21.659592 IP 10.26.12.22.50002 > 238.6.6.36.50002: UDP, length 135
12:58:21.659842 IP 10.26.12.22.50002 > 238.6.6.36.50002: UDP, length 242
12:58:21.660674 IP 10.26.12.22.50002 > 238.6.6.36.50002: UDP, length 242
12:58:21.660743 IP 10.26.12.22.50002 > 238.6.6.36.50002: UDP, length 84
12:58:21.662327 IP 10.26.12.22.50002 > 238.6.6.36.50002: UDP, length 84
12:58:21.669154 IP 10.26.12.22.50002 > 238.6.6.36.50002: UDP, length 161
12:58:21.669365 IP 10.26.12.22.50002 > 238.6.6.36.50002: UDP, length 166
12:58:21.670792 IP 10.26.12.22.60002 > 238.230.230.100.60002: UDP, length 49
12:58:21.670796 IP 10.26.12.22.60002 > 238.230.230.100.60002: UDP, length 49
12:58:21.670798 IP 10.26.12.22.60002 > 238.230.230.100.60002: UDP, length 49
12:58:21.670799 IP 10.26.12.22.60002 > 238.230.230.100.60002: UDP, length 49
But the application is not able to pick up any data flow, i.e., the application runs as if the multicast data subscription is unsuccessful.
The support team assures me that there is no problem with the test application, because it is running fine on other servers. Since I am having a new server, it is possible that some settings on the server are not right.
I am wondering what Linux settings shall I look for which potentially may stop the application receiving the multicast data, even thought tcpdump can see the data. Missing libraries or packages?
Thanks.
First off, it's worth checking that RHEL 6 has multicast support enabled at the kernel level. (it probably does but I don't have RHEL 6 available to check)
Make sure that the /proc/net/igmp file exists.
Also check that the multicast address range is routed to the interface that you're expecting. If this is incorrect you can have some interesting symptoms where you receive multicast only while tcpdump is (promiscuously) sniffing packets. This can also be the case if your NIC doesn't properly support multicast. Some older NICs may also need to be set to promiscuous mode to receive any multicast, regardless of the multicast setting shown in ifconfig.
Another thing to do is to check the contents of the /proc/net/igmp file while your test application is running.
The /proc/net/igmp file will contain a list of all of the multicast group addresses that the server is actively receiving. If there is an entry in the "Group" column that corresponds to the multicast group address that the test application is meant to be receiving (in your case 238.6.6.36 and 238.230.230.100) then the IP_ADD_MEMBERSHIP (or IP_ADD_SOURCE_MEMBERSHIP) socket options have probably been called correctly, and on the correct NIC. Note that the Group column lists the multicast group addresses in hex and backwards - so 238.6.6.36 will be listed as 240606EE.
Your situation may be more complicated if you have a multicast router (eg. Xorp, igmpproxy) running on the same machine on which you're running the test application.
If this is the case you should also investigate the /proc/net/ip_mr_vif and /proc/net/ip_mr_cache files to ensure that there are appropriate entries.
pls check on switch level.In my case i was stuck with Clustering. My cluster only will work on mulitcast. But i was facing some packet lose in mulitcast. It was too strange for me. But eventually i got the solution from one of my best friends(google). I have just disable IGMP on my switch level and it's working fine..
I had a similar problem on a RHEL 6 machine. I resolved it by adding the required UDP port to the allowed ports through the firewall. Try adding udp port 50002.

Resources